import Foundation
let pattern = ##"(\w*)@((\w*\|\w*#{0,1})*)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)