const regex = /(\w*)@((\w*\|\w*#{0,1})*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w*)@((\\w*\\|\\w*#{0,1})*)', 'g')
const str = `foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);