re = /(\w*)@((\w*\|\w*#{0,1})*)/
str = 'foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result