$re = '/(\w*)@((\w*\|\w*#{0,1})*)/';
$str = 'foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;