#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((.+?)(another?|anoother?)(.+))$"
Local $sString = "this is the anoother line\n" & @CRLF & _
"this is the another line\n" & @CRLF & _
"this is the anothe line\n" & @CRLF & _
"this is the other line\n"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)