import Foundation
let pattern = #"^((.+?)(another?|anoother?)(.+))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this is the anoother line\n
this is the another line\n
this is the anothe line\n
this is the other line\n
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)