use strict;
my $str = 'this is the anoother line\\n
this is the another line\\n
this is the anothe line\\n
this is the other line\\n';
my $regex = qr/^((.+?)(another?|anoother?)(.+))$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";