const regex = /^((.+?)(another?|anoother?)(.+))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((.+?)(another?|anoother?)(.+))$', 'gm')
const str = `this is the anoother line\\n
this is the another line\\n
this is the anothe line\\n
this is the other line\\n`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);