import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((.+?)(another?|anoother?)(.+))$";
final String string = "this is the anoother line\\n\n"
+ "this is the another line\\n\n"
+ "this is the anothe line\\n\n"
+ "this is the other line\\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}