re = /^((.+?)(another?|anoother?)(.+))$/m
str = 'this is the anoother line\\n
this is the another line\\n
this is the anothe line\\n
this is the other line\\n'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result