using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[A-Z]:|\\|(?:\.{1,2}[\/\\])+)[\w+\\\s_\(\)\/]+(?:\.\w+)*";
string input = @" # URLs
""https://www.google.com"",
""www.google.com"",
""www.google.com www.example.com"",
# Paths
""/foo/bar"",
""/foo/bar.txt"",
""../foo/bar/"",
""../../foo/bar/"",
""./foo/bar/"",
""./foo/bar.txt"",
""\\foo\\bar.txt"",
""C:\\foo\\bar.txt"",
""C:/foo/bar.txt"",
# Mixed
""https://www.google.com ./foo/bar.txt"",
""[markdown](./foo/bar.txt)"",
""Lorem ipsum ./foo_bar/baz.txt Lorem ipsum"",";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}