const regex = new RegExp('(?:[A-Z]:|\\\\|(?:\\.{1,2}[\\/\\\\])+)[\\w+\\\\\\s_\\(\\)\\/]+(?:\\.\\w+)*', 'g')
const str = ` # URLs
"https://www.google.com",
"www.google.com",
"www.google.com www.example.com",
# Paths
"/foo/bar",
"/foo/bar.txt",
"../foo/bar/",
"../../foo/bar/",
"./foo/bar/",
"./foo/bar.txt",
"\\\\foo\\\\bar.txt",
"C:\\\\foo\\\\bar.txt",
"C:/foo/bar.txt",
# Mixed
"https://www.google.com ./foo/bar.txt",
"[markdown](./foo/bar.txt)",
"Lorem ipsum ./foo_bar/baz.txt Lorem ipsum",`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}