import Foundation
let pattern = #"(?:[A-Z]:|\\|(?:\.{1,2}[\/\\])+)[\w+\\\s_\(\)\/]+(?:\.\w+)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
# URLs
"https://www.google.com",
"www.google.com",
"www.google.com www.example.com",
# Paths
"/foo/bar",
"/foo/bar.txt",
"../foo/bar/",
"../../foo/bar/",
"./foo/bar/",
"./foo/bar.txt",
"\\foo\\bar.txt",
"C:\\foo\\bar.txt",
"C:/foo/bar.txt",
# Mixed
"https://www.google.com ./foo/bar.txt",
"[markdown](./foo/bar.txt)",
"Lorem ipsum ./foo_bar/baz.txt Lorem ipsum",
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)