import re
regex = re.compile(r"(?:[A-Z]:|\\|(?:\.{1,2}[\/\\])+)[\w+\\\s_\(\)\/]+(?:\.\w+)*")
test_str = (" # URLs\n"
" \"https://www.google.com\",\n"
" \"www.google.com\",\n"
" \"www.google.com www.example.com\",\n\n"
" # Paths\n"
" \"/foo/bar\",\n"
" \"/foo/bar.txt\",\n"
" \"../foo/bar/\",\n"
" \"../../foo/bar/\",\n"
" \"./foo/bar/\",\n"
" \"./foo/bar.txt\",\n"
" \"\\\\foo\\\\bar.txt\",\n"
" \"C:\\\\foo\\\\bar.txt\",\n"
" \"C:/foo/bar.txt\",\n\n"
" # Mixed\n"
" \"https://www.google.com ./foo/bar.txt\",\n"
" \"[markdown](./foo/bar.txt)\",\n"
" \"Lorem ipsum ./foo_bar/baz.txt Lorem ipsum\",")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")