$re = '/(?:[A-Z]:|\\\\|(?:\.{1,2}[\/\\\\])+)[\w+\\\\\s_\(\)\/]+(?:\.\w+)*/';
$str = ' # URLs
"https://www.google.com",
"www.google.com",
"www.google.com www.example.com",
# Paths
"/foo/bar",
"/foo/bar.txt",
"../foo/bar/",
"../../foo/bar/",
"./foo/bar/",
"./foo/bar.txt",
"\\\\foo\\\\bar.txt",
"C:\\\\foo\\\\bar.txt",
"C:/foo/bar.txt",
# Mixed
"https://www.google.com ./foo/bar.txt",
"[markdown](./foo/bar.txt)",
"Lorem ipsum ./foo_bar/baz.txt Lorem ipsum",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);