import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[A-Z]:|\\\\|(?:\\.{1,2}[\\/\\\\])+)[\\w+\\\\\\s_\\(\\)\\/]+(?:\\.\\w+)*";
final String string = " # URLs\n"
+ " \"https://www.google.com\",\n"
+ " \"www.google.com\",\n"
+ " \"www.google.com www.example.com\",\n\n"
+ " # Paths\n"
+ " \"/foo/bar\",\n"
+ " \"/foo/bar.txt\",\n"
+ " \"../foo/bar/\",\n"
+ " \"../../foo/bar/\",\n"
+ " \"./foo/bar/\",\n"
+ " \"./foo/bar.txt\",\n"
+ " \"\\\\foo\\\\bar.txt\",\n"
+ " \"C:\\\\foo\\\\bar.txt\",\n"
+ " \"C:/foo/bar.txt\",\n\n"
+ " # Mixed\n"
+ " \"https://www.google.com ./foo/bar.txt\",\n"
+ " \"[markdown](./foo/bar.txt)\",\n"
+ " \"Lorem ipsum ./foo_bar/baz.txt Lorem ipsum\",";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}