package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[A-Z]:|\\|(?:\.{1,2}[\/\\])+)[\w+\\\s_\(\)\/]+(?:\.\w+)*`)
var str = ` # URLs
"https://www.google.com",
"www.google.com",
"www.google.com www.example.com",
# Paths
"/foo/bar",
"/foo/bar.txt",
"../foo/bar/",
"../../foo/bar/",
"./foo/bar/",
"./foo/bar.txt",
"\\foo\\bar.txt",
"C:\\foo\\bar.txt",
"C:/foo/bar.txt",
# Mixed
"https://www.google.com ./foo/bar.txt",
"[markdown](./foo/bar.txt)",
"Lorem ipsum ./foo_bar/baz.txt Lorem ipsum",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}