# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\/[a-z0–9\/_-]*(?<!\/))([^\/]*)$/$1\/$2/gm;t' <<< "/news
/news?param1=value1
/news#anchor?param1=value1
/not_me/
"