const regex = new RegExp('^(/[a-z0–9/_-]*(?<!/))([^/]*)$', 'gm')
const str = `/news
/news?param1=value1
/news#anchor?param1=value1
/not_me/
`;
const subst = `$1/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);