import re
regex = re.compile(r"^(/[a-z0–9/_-]*(?<!/))([^/]*)$", flags=re.MULTILINE)
test_str = ("/news\n"
"/news?param1=value1\n"
"/news#anchor?param1=value1\n"
"/not_me/\n")
subst = "$1/$2"
result = regex.sub(subst, test_str)
if result:
print(result)