use strict;
my $str = '/news
/news?param1=value1
/news#anchor?param1=value1
/not_me/
';
my $regex = qr~^(/[a-z0–9/_-]*(?<!/))([^/]*)$~mp;
my $subst = '$1/$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";