import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(/[a-z0–9/_-]*(?<!/))([^/]*)$";
final String string = "/news\n"
+ "/news?param1=value1\n"
+ "/news#anchor?param1=value1\n"
+ "/not_me/\n";
final String subst = "$1/$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}