$re = '~^(/[a-z0–9/_-]*(?<!/))([^/]*)$~m';
$str = '/news
/news?param1=value1
/news#anchor?param1=value1
/not_me/
';
$subst = "$1/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;