#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(/[a-z0–9/_-]*(?<!/))([^/]*)$"
Local $sString = "/news" & @CRLF & _
"/news?param1=value1" & @CRLF & _
"/news#anchor?param1=value1" & @CRLF & _
"/not_me/" & @CRLF & _
""
Local $sSubst = "$1/$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)