using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(/[a-z0–9/_-]*(?<!/))([^/]*)$";
string substitution = @"$1/$2";
string input = @"/news
/news?param1=value1
/news#anchor?param1=value1
/not_me/
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}