import Foundation
let pattern = #"^(/[a-z0–9/_-]*(?<!/))([^/]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/news
/news?param1=value1
/news#anchor?param1=value1
/not_me/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)