# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^-]*?)\s*-\s*/$1, '/gm;t' <<< "123 - foo - asdf
234 - bar - abcdefg
345 - foobar and hello world"