const regex = /^([^-]*?)\s*-\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^-]*?)\\s*-\\s*', 'gm')
const str = `123 - foo - asdf
234 - bar - abcdefg
345 - foobar and hello world`;
const subst = `$1, '`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);