import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^-]*?)\\s*-\\s*";
final String string = "123 - foo - asdf\n"
+ "234 - bar - abcdefg\n"
+ "345 - foobar and hello world";
final String subst = "$1, '";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}