$re = '/^([^-]*?)\s*-\s*/m';
$str = '123 - foo - asdf
234 - bar - abcdefg
345 - foobar and hello world';
$subst = "$1, '";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;