import Foundation
let pattern = #"^([^-]*?)\s*-\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123 - foo - asdf
234 - bar - abcdefg
345 - foobar and hello world
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1, '"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)