using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^-]*?)\s*-\s*";
string substitution = @"$1, '";
string input = @"123 - foo - asdf
234 - bar - abcdefg
345 - foobar and hello world";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}