#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^-]*?)\s*-\s*"
Local $sString = "123 - foo - asdf" & @CRLF & _
"234 - bar - abcdefg" & @CRLF & _
"345 - foobar and hello world"
Local $sSubst = "$1, '"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)