import re
regex = re.compile(r"^([^-]*?)\s*-\s*", flags=re.MULTILINE)
test_str = ("123 - foo - asdf\n"
"234 - bar - abcdefg\n"
"345 - foobar and hello world")
subst = "$1, '"
result = regex.sub(subst, test_str)
if result:
print(result)