# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\|\d+][^][()]*\([^()]*\)//g;t' <<< "Do [|83] blabla83
Bo [|18] pz ([]?:)\n la :\n[pl]
Co [|76] pp ([]?:)
Do [|83] blabla 83 Bo [|18] blabla 18\n la :\n[pl] Co [|76] blabla76
Do [|83] blabla done Bo [|18] pz ([]?:)\n la :\n[pl] Co [|76] pp ([]?:)
"