package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\|\d+][^][()]*\([^()]*\)`)
var str = `Do [|83] blabla83
Bo [|18] pz ([]?:)\n la :\n[pl]
Co [|76] pp ([]?:)
Do [|83] blabla 83 Bo [|18] blabla 18\n la :\n[pl] Co [|76] blabla76
Do [|83] blabla done Bo [|18] pz ([]?:)\n la :\n[pl] Co [|76] pp ([]?:)
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}