#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[\|\d+][^][()]*\([^()]*\)"
Local $sString = "Do [|83] blabla83" & @CRLF & _
"Bo [|18] pz ([]?:)\n la :\n[pl] " & @CRLF & _
"Co [|76] pp ([]?:)" & @CRLF & _
"" & @CRLF & _
"Do [|83] blabla 83 Bo [|18] blabla 18\n la :\n[pl] Co [|76] blabla76" & @CRLF & _
"" & @CRLF & _
"Do [|83] blabla done Bo [|18] pz ([]?:)\n la :\n[pl] Co [|76] pp ([]?:)" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)