# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\|\d+][^][()]*\([^()]*\)"
test_str = ("Do [|83] blabla83\n"
"Bo [|18] pz ([]?:)\\n la :\\n[pl] \n"
"Co [|76] pp ([]?:)\n\n"
"Do [|83] blabla 83 Bo [|18] blabla 18\\n la :\\n[pl] Co [|76] blabla76\n\n"
"Do [|83] blabla done Bo [|18] pz ([]?:)\\n la :\\n[pl] Co [|76] pp ([]?:)\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.