import Foundation
let pattern = #"\[\|\d+][^][()]*\([^()]*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Do [|83] blabla83
Bo [|18] pz ([]?:)\n la :\n[pl]
Co [|76] pp ([]?:)
Do [|83] blabla 83 Bo [|18] blabla 18\n la :\n[pl] Co [|76] blabla76
Do [|83] blabla done Bo [|18] pz ([]?:)\n la :\n[pl] Co [|76] pp ([]?:)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)