const regex = /\[\|\d+][^][()]*\([^()]*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\|\\d+][^][()]*\\([^()]*\\)', 'g')
const str = `Do [|83] blabla83
Bo [|18] pz ([]?:)\\n la :\\n[pl]
Co [|76] pp ([]?:)
Do [|83] blabla 83 Bo [|18] blabla 18\\n la :\\n[pl] Co [|76] blabla76
Do [|83] blabla done Bo [|18] pz ([]?:)\\n la :\\n[pl] Co [|76] pp ([]?:)
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);