// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\|\d+][^][()]*\([^()]*\)").unwrap();
let string = "Do [|83] blabla83
Bo [|18] pz ([]?:)\\n la :\\n[pl]
Co [|76] pp ([]?:)
Do [|83] blabla 83 Bo [|18] blabla 18\\n la :\\n[pl] Co [|76] blabla76
Do [|83] blabla done Bo [|18] pz ([]?:)\\n la :\\n[pl] Co [|76] pp ([]?:)
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}