using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\|\d+][^][()]*\([^()]*\)";
string substitution = @"";
string input = @"Do [|83] blabla83
Bo [|18] pz ([]?:)\n la :\n[pl]
Co [|76] pp ([]?:)
Do [|83] blabla 83 Bo [|18] blabla 18\n la :\n[pl] Co [|76] blabla76
Do [|83] blabla done Bo [|18] pz ([]?:)\n la :\n[pl] Co [|76] pp ([]?:)
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}