use strict;
my $str = 'Do [|83] blabla83
Bo [|18] pz ([]?:)\\n la :\\n[pl]
Co [|76] pp ([]?:)
Do [|83] blabla 83 Bo [|18] blabla 18\\n la :\\n[pl] Co [|76] blabla76
Do [|83] blabla done Bo [|18] pz ([]?:)\\n la :\\n[pl] Co [|76] pp ([]?:)
';
my $regex = qr/\[\|\d+][^][()]*\([^()]*\)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";