re = /\[\|\d+][^][()]*\([^()]*\)/
str = 'Do [|83] blabla83
Bo [|18] pz ([]?:)\\n la :\\n[pl]
Co [|76] pp ([]?:)
Do [|83] blabla 83 Bo [|18] blabla 18\\n la :\\n[pl] Co [|76] blabla76
Do [|83] blabla done Bo [|18] pz ([]?:)\\n la :\\n[pl] Co [|76] pp ([]?:)
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result