using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?";
string input = @"Requester
jeff@gmail.com
Loren Goodtree (lg@gmail.com)
To view the completed version, please see the file attached.
Best,
Matt Hernandez
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}