// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?").unwrap();
let string = "Requester
jeff@gmail.com
Loren Goodtree (lg@gmail.com)
To view the completed version, please see the file attached.
Best,
Matt Hernandez
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}