$re = '/Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?/m';
$str = 'Requester
jeff@gmail.com
Loren Goodtree (lg@gmail.com)
To view the completed version, please see the file attached.
Best,
Matt Hernandez
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);