import re
regex = re.compile(r"Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?", flags=re.MULTILINE)
test_str = ("Requester\n\n"
"jeff@gmail.com\n\n"
"Loren Goodtree (lg@gmail.com)\n\n"
"To view the completed version, please see the file attached.\n\n"
"Best,\n\n"
"Matt Hernandez\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")