package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?`)
var str = `Requester
jeff@gmail.com
Loren Goodtree (lg@gmail.com)
To view the completed version, please see the file attached.
Best,
Matt Hernandez
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}