use strict;
my $str = 'Requester
jeff@gmail.com
Loren Goodtree (lg@gmail.com)
To view the completed version, please see the file attached.
Best,
Matt Hernandez
';
my $regex = qr/Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}